Cos'è ElectroYou | Login Iscriviti

ElectroYou - la comunità dei professionisti del mondo elettrico

Riparazione alimentatore switching 12V - 6,5A

Tecniche per la costruzione e la riparazione di apparecchiature elettriche e non. Ricerca guasti. Adattamenti e riutilizzazioni

Moderatore: Foto Utentestefanob70

0
voti

[151] Re: Riparazione alimentatore switching 12V - 6,5A

Messaggioda Foto UtenteIsidoroKZ » 12 mag 2021, 23:35

Alan18 ha scritto:Non sono sicuro di aver capito.

In effetti e` complicato e non l'ho spiegato bene. Con l'alimentatore non alimentato misura la resistenza di uscita, con il rosso del tester sul positivo dell'uscita. Queste le istruzioni che avevo gia` dato, modificate dopo aver guardato meglio lo schema (mi ero perso R42!)

IsidoroKZ ha scritto:Prova a misurare la resistenza che si vede in uscita con l'alim. spento: se metti il positivo del multimetro sul positivo dell'uscita dovresti vedere una resistenza dalle parti di 300Ω




Se misuri un corto (pochi ohm o meno) potrebbe essere un condensatore di uscita, da provare ad uno ad uno. Se invece misuri circa 300Ω, va bene.
Alan18 ha scritto:... se escludessimo completamente il circuito in uscita rimuovendo D7 e C14?

Pessima idea! Se il problema e` un condensatore di uscita in corto, togliendo i diodi elimini il cortocircuito MA elimini anche la retroazione. A quel punto il convertitore spinge al massimo la potenza di uscita, che puo` solo andare sull'alimentazione ausiliaria e sul MOS e il circuito esplode :(
Alan18 ha scritto:E rimuovendo inoltre l'optoisolatore, avendo cura di chiudere il circuito al primario?

Non ho capito cosa vuol dire chiudere il circuito al primario. Se dici di mettere in corto i nodi cui e` collegato il fototransistor non va bene: questo blocca il funzionamento dell'alimentatore.
Alan18 ha scritto:Se in queste condizioni continuiamo ad avere oscillazione su C5,


Variazioni di tensione su C5 sono perfettamente normali, quello che mi lascia perplesso e` che si scarichi velocemente. La prova da fare e` quella che avevo gia` indicato.

Stacca R8 da un lato e alimenta da rete il circuito, sempre con la lampadina. Togli la spina e misura quanto velocemente scende la tensione su C5.
Con R8 staccata il MOS e` aperto (spero, come hai provato il MOS?) e il condensatore dovrebbe scaricarsi molto lentamente, in 10s dovresti ancora avere oltre 100V.

Non ho guardato l'impdenzimetro con Arduino, se hai gia` i componenti pronti prova a farlo, tanto siamo nel mood "divertiamoci a fare cose complicate".
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
112,7k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 19712
Iscritto il: 17 ott 2009, 0:00

0
voti

[152] Re: Riparazione alimentatore switching 12V - 6,5A

Messaggioda Foto UtenteAlan18 » 13 mag 2021, 17:54

IsidoroKZ ha scritto:In effetti e` complicato e non l'ho spiegato bene.

No, sono certo che gli altri hanno capito. Purtroppo molte cose scontate per chi ha molte conoscenze, non sono scontate per me. #-o

IsidoroKZ ha scritto:Prova a misurare la resistenza che si vede in uscita con l'alim. spento

La resistenza in uscita è pari a 358\,\mathrm{\Omega}, quindi in linea con le aspettative di, più o meno, 300\,\mathrm{\Omega}.
Se non ho capito male, è inutile smontarli uno a uno. I condensatori dovrebbero essere tutti buoni, giusto?

IsidoroKZ ha scritto:Variazioni di tensione su C5 sono perfettamente normali, quello che mi lascia perplesso e` che si scarichi velocemente.

Non vorrei essermi espresso male io, ma penso che tu abbia scambiato C1 (condensatore di livellamento in uscita dal ponte raddrizzatore) con C5 (condensatore di "alimentazione" del PWM controller). Non è C5 che si scarica rapidamente, ma C1.
Cerco di fare chiarezza su quello che ho constatato:
C1 con SMPS alimentato con tensione di rete, si scarica molto rapidamente una volta staccata la tensione.
C5 con SMPS alimentato con tensione di rete, presenta un'oscillazione tra 12,5\,\mathrm{V} e 14\,\mathrm{V}.
A tal proposito ho misurato approssimativamente la velocità di scaricamento di C1 (Foto UtenteIsidoroKZ, ho immaginato ti riferissi a C1 e non a C5, quando mi hai scritto di eseguire questo test) . Ho fatto la prova sia con R8 montata, sia senza R8. I risultati ottenuti sono stati gli stessi e sono quelli nella tabella seguente.
Tempo di scarica C1.jpg

IsidoroKZ ha scritto:Con R8 staccata il MOS e` aperto (spero, come hai provato il MOS?) e il condensatore dovrebbe scaricarsi molto lentamente, in 10s dovresti ancora avere oltre 100V.

Si, infatti siamo a circa 135\,\mathrm{V}. La tensione poi, alla lunga, come riportato in tabella, tende a 0 V. Continua a scendere anche dopo i 60 secondi, ma mi sembrava superfluo riportare i dati.
Per quanto riguarda il mosfet, l'ho smontato e ritestato per sicurezza. Elenco i passaggi fatti.
Multimetro in prova diodi.
Giunzione D-S:
rosso su D e nero su S \Rightarrow O.L.
rosso su S e nero su D \Rightarrow 540\,\mathrm{mV}
Ho caricato la capacità di gate: rosso su G e nero su D
Ho testato il canale D-S:
rosso su D e nero su S \Rightarrow la tensione parte da circa 500\,\mathrm{mV} e sale in qualche secondo fino a 3\,\mathrm{V}, quando poi diventa O.L.
Invertendo i puntali ho di nuovo 540\,\mathrm{mV}.
Multimetro in continuità \Rightarrow provati tutti i pin tra loro in tutte le combinazioni e non c'è continuità.
E' giusto controllare così un mosfet a canale N?

Ho notato inoltre che la tensione presente su C1, con SMPS alimentato da rete, è perfettamente stabile a 321\,\mathrm{V}.
C5 invece continua ad oscillare tra i valori sopra indicati.
Anche Vref, in questa situazione continua a non essere stabile.

Per quanto riguarda la strumentazione suggerita da Foto Utentestefanopc ho deciso di prendere questo RCL meter da assemblare, che pur arrivando dalla Cina, è prevista una spedizione rapida in circa 10 giorni e la spesa è più o meno la stessa del link di ebay che mi ha fornito. I tempi di spedizione su ebay erano però biblici. In più questo ha una scocca protettiva. Voglio però ugualmente cimentarmi nel progetto Arduino, che spero di realizzare senza intoppi a breve.
Non ho capito bene la sostituzione che hai fatto nel tuo...zoccolo tulip? Cosa cambia da quello già in dotazione. E perché hai messo i condensatori al tantalio al posto di quelli forniti? Immagino siano migliori...ma in cosa?
Grazie.
Avatar utente
Foto UtenteAlan18
309 1 2 6
Frequentatore
Frequentatore
 
Messaggi: 168
Iscritto il: 8 mar 2020, 13:11

0
voti

[153] Re: Riparazione alimentatore switching 12V - 6,5A

Messaggioda Foto UtenteIsidoroKZ » 13 mag 2021, 19:52

Alan18 ha scritto:La resistenza in uscita è pari a 358\,\mathrm{\Omega}, quindi in linea con le aspettative di, più o meno, 300\,\mathrm{\Omega}.
Se non ho capito male, è inutile smontarli uno a uno. I condensatori dovrebbero essere tutti buoni, giusto?

Giusto, non ci sono cortocircuiti sull'uscita, i condensatori sono a posto.
Alan18 ha scritto:Non vorrei essermi espresso male io, ma penso che tu abbia scambiato C1 (condensatore di livellamento in uscita dal ponte raddrizzatore) con C5

Intendevo C1 e ho scritto C5. Il rincoglionimento avanza!
Alan18 ha scritto:C5 con SMPS alimentato con tensione di rete, presenta un'oscillazione tra 12,5\,\mathrm{V} e 14\,\mathrm{V}.

Le letture in questo caso non sono vere ma mediate dal multimetro. La tensione in realta` varia fra le due soglie di 16V e 10V (o quelle che dice il data sheet). La tensione sale adagio e scende in fretta, ma con un multimetro non lo si riesce a vedere.
Alan18 ha scritto:A tal proposito ho misurato approssimativamente la velocità di scaricamento di C1 ... Ho fatto la prova sia con R8 montata, sia senza R8. I risultati ottenuti sono stati gli stessi e sono quelli nella tabella seguente.

Non hai messo la figura.
Alan18 ha scritto:Si, infatti siamo a circa 135\,\mathrm{V}. La tensione poi, alla lunga, come riportato in tabella, tende a 0 V. Continua a scendere anche dopo i 60 secondi, ma mi sembrava superfluo riportare i dati.

Quando stacchi l'alimentazione, C5 continua a tenere vivo il controllore che comanda Q1 e quindi assorbe corrente da C1 che si scarica in fretta. Se non c'e` R8 invece C1 si scarica praticamente solo attraverso R15 e ci mette parecchio tempo, costante di tempo dalle parti di 10s.
Alan18 ha scritto:Per quanto riguarda il mosfet, l'ho smontato e ritestato per sicurezza. Elenco i passaggi fatti.
...
E' giusto controllare così un mosfet a canale N?

Quasi. L'unico cambiamento che farei e` quando carichi il gate, al posto di usare il multimetro che se va bene da` 3V, userei una pila da 9V, in modo da avere una canale ben formato. 3V di tensione gate source e` appena dalle parti della soglia. Comunque il MOS sta bene di salute.
Alan18 ha scritto:Ho notato inoltre che la tensione presente su C1, con SMPS alimentato da rete, è perfettamente stabile a 321\,\mathrm{V}.
C5 invece continua ad oscillare tra i valori sopra indicati.
Anche Vref, in questa situazione continua a non essere stabile.

Se non c'e` R8 su C1 non c'e` praticamente ripple, quindi tensione stabile. Se c'e` R8 mi aspett un po' piu` di ripple su C1. Con funzionamento corretto e massimo carico in uscita mi aspetto una ventina di volt di ripple su C1.

In definitiva c'e`corrente sul primario del magnetico (*) ma non esce nulla :(. I condensatori di uscita sembrano a posto, potrebbe essere una spira in corto nel magnetico oppure un corto sul PCB.
Potrebbe servire la consulenza di qualche potente che le cose le sa, a me non vengono altre idee. Foto Utentecarloc, Foto Utentemarioursino ci siete?

(*) hai notato che ho (quasi) sempre detto magnetico mentre non ho mai usato la parola trasformatore? Tranne in un caso in cui mi e`scappata :(. Chissa` perche'? :mrgreen:
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
112,7k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 19712
Iscritto il: 17 ott 2009, 0:00

0
voti

[154] Re: Riparazione alimentatore switching 12V - 6,5A

Messaggioda Foto UtenteAlan18 » 13 mag 2021, 20:20

IsidoroKZ ha scritto:Non hai messo la figura.

Eh...il rinc....mento appunto! #-o

Tempo di scarica di C1. Sia con R8 che senza. Sempre uguale.
Tempo di scarica C1.jpg
Avatar utente
Foto UtenteAlan18
309 1 2 6
Frequentatore
Frequentatore
 
Messaggi: 168
Iscritto il: 8 mar 2020, 13:11

0
voti

[155] Re: Riparazione alimentatore switching 12V - 6,5A

Messaggioda Foto UtenteAlan18 » 14 mag 2021, 17:39

Alan18 ha scritto:Se non c'e` R8 su C1 non c'e` praticamente ripple, quindi tensione stabile. Se c'e` R8 mi aspett un po' piu` di ripple su C1. Con funzionamento corretto e massimo carico in uscita mi aspetto una ventina di volt di ripple su C1.

Per sicurezza ho riprovato con R8 montata, però non c'è alcun ripple. O se c'è, è minuscolo. C'è giusto un 0,1 V che balla.

Alan18 ha scritto:Quando stacchi l'alimentazione, C5 continua a tenere vivo il controllore che comanda Q1 e quindi assorbe corrente da C1 che si scarica in fretta. Se non c'e` R8 invece C1 si scarica praticamente solo attraverso R15 e ci mette parecchio tempo, costante di tempo dalle parti di 10s.

Anche questa cosa, in realtà non si verifica. I tempi sono praticamente identici.

Alan18 ha scritto:3V di tensione gate source e` appena dalle parti della soglia.

E' per questo che quando verifico il canale D-S, il multimetro mi segna O.L. proprio quando la tensione arriva a 3 V? Dipende da quanto ho caricato il gate?

Alan18 ha scritto:(*) hai notato che ho (quasi) sempre detto magnetico mentre non ho mai usato la parola trasformatore? Tranne in un caso in cui mi e`scappata . Chissa` perche'?

Una domanda delle tue, ci vuole ogni tanto :ok:
Provo a rispondere in base a quello che so. In teoria "trasformatore" indica tutto l'insieme di nucleo, avvolgimento primario ed avvolgimento secondario. Noi sospettiamo una spira in corto sul lato dell'avvolgimento primario. Sappiamo che l'avvolgimento primario, attraversato da una corrente variabile, genera un campo magnetico variabile che induce una tensione sull'avvolgimento secondario. Quindi, quando dici "magnetico", lo dici perché il campo magnetico viene generato dalla corrente che attraversa l'avvolgimento primario, che è proprio quello sospettato di corto. per caso ci ho preso? Se (probabile) dovessi aver "violentato" la definizione di trasformatore, non abbiatene a male [-o<

Alan18 ha scritto:Potrebbe servire la consulenza di qualche potente che le cose le sa, a me non vengono altre idee. carloc, marioursino ci siete?

Mi sa che Foto Utentecarloc in particolare, va evocato come l'altra volta. Oppure, diceva lui, di nominare 3 volte il suo nome.... :mrgreen:
Per Foto Utentemarioursino invece, ho fiducia nel tag user.

Volevo chiedere un paio di cose ancora. Volevo capire un po' meglio in che modo una spira potrebbe andare in corto. Da quello che ho capito, un eccessivo surriscaldamento del filo (ad esempio) potrebbe deteriorare il suo rivestimento smaltato, pregiudicandone quindi l'isolamento. Il problema si verifica perché la spira in questione tocca direttamente il nucleo? Oppure il problema è che la spira senza isolamento tocca la parte isolata un'altra spira e quindi di tutto l'avvolgimento? E a livello teorico, cosa succede quando una spira è in corto? perché il trasformatore non fa più il suo dovere?

Ultima cosa. Come si determina la presenza di una spira in corto usando l'induttanzimetro? Intendo, a livello pratico. Una volta che ho realizzato il mio strumento per la misura dell'induttanza, cosa devo fare? Che risultati devo aspettarmi in caso di corto spira?

Grazie.
Avatar utente
Foto UtenteAlan18
309 1 2 6
Frequentatore
Frequentatore
 
Messaggi: 168
Iscritto il: 8 mar 2020, 13:11

0
voti

[156] Re: Riparazione alimentatore switching 12V - 6,5A

Messaggioda Foto UtenteIsidoroKZ » 14 mag 2021, 21:09

Alan18 ha scritto:Anche questa cosa, in realtà non si verifica. I tempi sono praticamente identici.


Fermi tutti, compresi gli orologi a pendolo, come diceva un mio amico!

C'e` qualcosa che non quadra. Ho capito che avevi detto che C1 si scarica in fretta poi ti ho detto di staccare R8 e di misurare la tensione su C1, che cala lentamente.

Ora dici che i tempi sono identici. Non capisco in quali condizioni. Spiega bene questo. Per il resto c'e` tempo.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
112,7k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 19712
Iscritto il: 17 ott 2009, 0:00

0
voti

[157] Re: Riparazione alimentatore switching 12V - 6,5A

Messaggioda Foto UtenteAlan18 » 14 mag 2021, 21:27

Si, avevo detto che C1 si scaricava velocemente, ma non avevo mai fatto un confronto dei tempi di scarica con R8 e senza R8. Fino alla tabella di ieri, con la prova che mi hai consigliato di fare.
Dalle prove che ho fatto, alimentando con tensione di rete, sia che R8 sia nel circuito, sia che R8 ne sia esclusa, i tempi di scaricamento di C1 dal momento in cui si toglie tensione, sono identici.
Avatar utente
Foto UtenteAlan18
309 1 2 6
Frequentatore
Frequentatore
 
Messaggi: 168
Iscritto il: 8 mar 2020, 13:11

0
voti

[158] Re: Riparazione alimentatore switching 12V - 6,5A

Messaggioda Foto UtenteIsidoroKZ » 14 mag 2021, 21:28

E quindi quando si scarica in fretta?
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
112,7k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 19712
Iscritto il: 17 ott 2009, 0:00

0
voti

[159] Re: Riparazione alimentatore switching 12V - 6,5A

Messaggioda Foto UtenteAlan18 » 14 mag 2021, 21:42

Ho capito forse il malinteso.
All'inizio avevo detto che C1 si scaricava in fretta una volta tolta tensione.
"Ignorantemente" pensavo che la tensione su C1, anche senza tensione di rete, dovesse rimanere bloccata intorno ai 300 V. Mi saranno rimasti impressi i video in cui caricavano un condensatore (da solo, fuori da circuito) e mostravano come questo mantenesse la tensione anche quando veniva staccato dai morsetti.
immagino che giustamente, tu che le cose le sai, hai inteso che si scarica più rapidamente del normale.
Io invece, che pensavo non dovesse calare di tensione, ho detto che si scaricava velocemente.
Se avessi detto solo che si scarica (senza velocemente), probabilmente mi avresti risposto che era normale. E mi avresti fatto calcolare la velocità con cui si scarica.
Spero di aver chiarito.
Sorry, colpa mia.
Avatar utente
Foto UtenteAlan18
309 1 2 6
Frequentatore
Frequentatore
 
Messaggi: 168
Iscritto il: 8 mar 2020, 13:11

0
voti

[160] Re: Riparazione alimentatore switching 12V - 6,5A

Messaggioda Foto UtenteIsidoroKZ » 14 mag 2021, 23:10

OK, capito.

Una misura che avrei dovuto chiedere di fare lungo tempo fa, e non ho mai chiesto: misura la resistenza degli avvolgimenti del magnetico, puoi farlo senza togliere il componente del circuito, poi riferisci: visto che la tensione su C1 non scende, potrebbe esserci il primario interrotto.
Per usare proficuamente un simulatore, bisogna sapere molta più elettronica di lui
Plug it in - it works better!
Il 555 sta all'elettronica come Arduino all'informatica! (entrambi loro malgrado)
Se volete risposte rispondete a tutte le mie domande
Avatar utente
Foto UtenteIsidoroKZ
112,7k 1 3 8
G.Master EY
G.Master EY
 
Messaggi: 19712
Iscritto il: 17 ott 2009, 0:00

PrecedenteProssimo

Torna a Costruzione, riparazione, riutilizzo

Chi c’è in linea

Visitano il forum: Nessuno e 9 ospiti