Pagina 1 di 3

Buffer per sensori resistivi

MessaggioInviato: 2 ott 2020, 1:47
da daniele1996
Ciao a tutti, nel realizzare un "buffer" montato allo scopo di amplificare il segnale in uscita da un sensore di temperatura (che sarebbe un partitore di tensione con una NTC) ho notato che ponticellando l'ingresso a massa all'uscita dell'amplificatore la tensione di uscita non è 0V ma circa 1,77V. Guardando nel datasheet (UA741) dell'amplificatore ci sono due piedini denominati OFFSET che andrebbero collegati ad un trimmer il cui cursore va collegato a massa e poi si dovrebbe regolare il trimmer, ma ho appena provato e non funziona... Non sto usando l'alimentazione duale, potrebbe essere questo il problema? in caso quale altro componente potrei usare al posto di questo?

Re: Buffer per sensori resistivi

MessaggioInviato: 2 ott 2020, 5:32
da IsidoroKZ
Fai gli schemi che si capiscano!

Il 741 non può essere usato a singola alimentazione, devi usare almeno l'lm358 o qualcosa di migliore. Prova a guardare questo articolo, anche se temo sia un po' complicato.

A proposito, avevo intenzione di scrivere anche la seconda puntata, poi non l'ho mai fatto :( Chissà che non sia la volta buona che lo scrivo.

Re: Buffer per sensori resistivi

MessaggioInviato: 2 ott 2020, 16:29
da daniele1996
Ottimo! fortunatamente sto utilizzando un alimentatore ATX e quindi ho la disponibilità della -12V, ho appena fatto la prova e funziona correttamente senza il trimmer sui pin OFFSET, certo devo passare un filo in più per l'alimentazione negativa, ma fa niente... l'importante è che funzioni correttamente! PS: Ho trovato questo sito dove spiega le applicazioni dell' ua741, lo posto magari a qualcuno può tornare utile

Re: Buffer per sensori resistivi

MessaggioInviato: 5 ott 2020, 1:10
da daniele1996
Questo integrato può essere utilizzato in questa maniera?

Tenendo conto che l'induttore è un sensore di carico e la resistenza è di 1K

Re: Buffer per sensori resistivi

MessaggioInviato: 5 ott 2020, 1:16
da IsidoroKZ
No, l'operazionale è saturo e quando passa corrente, se va male, defunge!

Re: Buffer per sensori resistivi

MessaggioInviato: 5 ott 2020, 1:17
da daniele1996
Sinceramente, non mi è chiaro...

Re: Buffer per sensori resistivi

MessaggioInviato: 5 ott 2020, 1:24
da IsidoroKZ
MI hai chiesto se puo` essere usato in quel modo, la risposta e` no :(

L'induttore cortocircuita in continua i due ingressi dell'operazionale, quindi questo, a causa delle tensioni di offset (che non sono eliminabili ne' compensabili), satura. Inoltre nel circuito di ingresso non c'e`nessun collegamento in continua verso il potenziale di riferimento (ground), e se i due ingressi non sono collegati in qualche modo a ground, l'operazionale satura.

Infine se sulla resistenza viene fuori una tensione troppo elevata, qualche decina di volt, l'operazionale rischia la pelle.

Hai messo il negativo sul 741? Funziona?

Re: Buffer per sensori resistivi

MessaggioInviato: 5 ott 2020, 1:31
da daniele1996
Si, ho messo l'alimentazione negativa e funziona correttamente.
Ma se invece lo collego così:

può risultare migliorato il circuito?

Re: Buffer per sensori resistivi

MessaggioInviato: 5 ott 2020, 1:35
da IsidoroKZ
Cosi` va quasi bene: l'uscita dell'operazionale adesso e` una sinusoide, che pero` va anche in negativo, quindi ha bisogno di una alimentazione negativa. Poi non e` detto che il circuito dopo sia contento delle tensioni negative.

Se non si deve avere una tensione negativa all'uscita dell'operazionale, bisogna usare il circuito che avevi linkato: Sensore induttivo, ponte raddrizzatore e resistenza di carico. A questo punto sulla resistenza la tensione e` solo positiva. L'operazionale ha ancora bisogno della tensione negativa per funzionare, a meno che non sia un operazionale single supply.

Re: Buffer per sensori resistivi

MessaggioInviato: 5 ott 2020, 1:43
da daniele1996
Il circuito di partenza (prelevato dallo stampato originale) è questo:

però così:

può risultare migliore?